
MATLAB TUTORIAL
How to Analyze fMRI on SPM

Independent Study in Psychology
Fall 2011



fMRI Datasets

Face fMRI Dataset:
http://www.fil.ion.ucl.ac.uk/spm/data/face_rep/

Face Group fMRI Dataset:
http://www.fil.ion.ucl.ac.uk/spm/data/face_rfx/spm
2_face_rfx.doc



Paradigm

• Randomized
presentation of 26
famous and 26 non-
famous grayscale
photographs

• Each face required a
judgment denoting
whether or not the
face was famous



fMRI Data Collection

• Images were acquired using continuous Echo-
Planar Imaging (EPI)
– TE = 40 ms
– TR = 2 s
– 24 descending slices

• 64 x 64 3 x 3 mm2

• 3 mm thick
• 1.5 mm gap



fMRI First-Level
Data Analysis



fMRI Data Files

• 351 Analyze format functional images
– sM03953_0005_*.img

• Analyze format structural images
– sM03953.img

***Create 2 subdirectories:
1) jobs and 2) categorical***



Step 1
Getting Started

• Open up MATLAB
• Go to “File” → “Set Path” → “Add with Subfolders” → Select

the dataset folder (I.e.,
Home\ZoeRavich4831\MATLAB\Datasets)
– “Do you want to

save this path for
future reference?”;
Click “No”

• Go to the Command
Window and type
“spm fmri” to open
up the fMRI GUI



Step 2
Display

• Press the DISPLAY button
– Select the first functional image
– Note orbitofrontal and inferior temporal drop-out

and ghosting
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Step 2
Display



Step 3
Realignment

• Select REALIGN (EST & RES) from the “Realign” drop-
down menu
– Highlight “Data” and select “New Session”; then

highlight the newly created “Session” option
– Select “Specify Files” and choose all of the

functional images using the filter ^s.*
– Save the job as realign.mat
– Press the “Run” button

• New files: rsM03953_0005_*.img,
meansM03953_0005_0006.img (the mean image),
and rp_sM03953_0005_0006.txt (the realignment
parameters; copy into the DIR/jobs directory)
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Step 3
Realignment



Step 4
Slice Timing Correction

• Press the SLICE TIMING button
– Highlight “Data” and select “New Sessions”
– Select “Specify Files” and choose all of the 351

realigned functional images using the filter ^r.*
• “Number of Slices”; Type “24”
• “TR”; Type “2”
• “TA”; Type “2 - 2/24”
• “Slice order”; Type “24:-1:1”
• “Reference Slice”; Type “12”

– Save the job as slice_timing.mat
– Press the “Run” button

• New files: arsM03953_0005_*.img
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Step 4
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Step 5
Coregistration

• Select COREGISTER (ESTIMATE) from the “Coregister”
drop-down menu
– Highlight “Reference Image” and select the

meansM03953_0007.img file
– Highlight “Source Image” and select the

sM03953_0007.img file
– Save the job as coreg.mat
– Press the “Run” button

• New files: sM03953_0007.img
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Step 5
Coregistration



Step 6
Segmentation

• Press the SEGMENT button
– Highlight “Data” and select the coregistered

sM03953_0007.img file
– Save the job as segment.mat
– Press the “Run” button

• New files: msM03953_0007.img, c*sM03953_0007.img
(the gray matter and white matter images) and
sM03953_0007_seg_sn.mat (the spatial
normalisation)

• Press the CHECK REG button
– Select the grey matter, white mater, and original

structural images
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Segmentation

1



Step 6
Segmentation

2

3

4



Step 6
Segmentation

5

7

6



Step 6
Segmentation
8

Processing…



Step 6
Segmentation

9

10

11



Step 6
Segmentation



Step 7
Normalise

• Select NORMALISE (WRITE) from the “Normalise”
drop-down menu
– Highlight “Data” and select “New Subject”
– Open “Subject”, highlight “Parameter File”, and

select the sM03953_0007_seg_sn.mat file
– Highlight “Images to Write” and select ^ar.* files

as well as the meansM03953_0005_006.img file
– Open “Writing Options” and change “Voxel

sizes” to [3 3 3]
– Save the job as normalise.mat
– Press the “Run” button

• New files: warsM03953_0005_*.img
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Step 7
Normalise (Optional)

• Select NORMALISE (WRITE) from the “Normalise”
drop-down menu
– Highlight “Data” and select “New Subject”
– Open “Subject”, highlight “Parameter File”, and

select the sM03953_0007_seg_sn.mat file
– Highlight “Images to Write” and select the

msM03953_0005_007.img file
– Open “Writing Options” and change “Voxel

sizes” to [1 1 1]
– Save the job as norm_struct.mat
– Press the “Run” button

• New files: warsM03953_0005_*.img
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Step 8
Smoothing

• Press the SMOOTH button
– Highlight “Images to Smooth” and select ^wms.*

files
– Save the job as smooth.mat
– Press the “Run” button

• New files: swmsM03953_0005_*.img
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Step 8
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Modelling Overview

1. Specify First Level
2. Estimate
3. Inference for Categorical Design
4. Statistical Tables
5. F-Contrasts
6. Testing Effects of Movement



Step 9
Specify First-Level (Part 1)

• At the MATLAB command prompt, type “load sots”
and then “moveparts.txt”

• Press the SPECIFY 1ST-LEVEL button
– Highlight “Units for design” in the “Timing

parameters” section and select “Scans”
• “Interscan interval”; Type “2”
• “Microtime resolution”; Type “24”
• “Microtime onset”; Type “12”

– Highlight “Data and Design” and select “New
Subject/Session”; then highlight “Scans” and use
the ^swar.* filter to choose 351 functional images
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Step 9
Specify First-Level (Part 2)

– Highlight “Conditions”, select “New condition”,
and open the newly created “Condition” option

• “Name”; Type “N1”
• “Onsets”; Type “sot{1}”
• “Durations”; Type “0”

– Highlight “Conditions”, select “Replicate
condition”, and then open the newly created
“Condition” option

• “Name”; Type “N2”
• “Onsets”; Type “sot{2}”
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Step 9
Specify First-Level (Part 3)

– Highlight “Conditions”, select “Replicate
condition”, and then open the newly created
“Condition” option

• “Name”; Type “F1”
• “Onsets”; Type “sot{3}”

– Highlight “Conditions”, select “Replicate
condition”, and then open the newly created
“Condition” option

• “Name”; Type “F2”
• “Onsets”; Type “sot{4}”

– Highlight “Multiple Regressions” and select the
movepars.txt file



Step 9
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Step 9
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Step 9
Specify First-Level (Part 4)

– Highlight “Factorial Design”, select “New Factor”,
and open the newly created “Factor” option

• “Name”; Type “Fam”
• “Levels”; Type “2”

– Highlight “Factorial Design”, select “New Factor”,
and then open the newly created “Factor”
option

• “Name”; Type “Rep”
• “Levels”; Type “2”

– Highlight “Basis Functions” and select “Canonical
HRF”; choose “Model derivatives” and then
“Time and Dispersion derivatives”



Step 9
Specify First-Level (Part 4)
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Step 9
Specify First-Level (Part 5)

– Highlight “Directory” and select the
DIR/categorical directory

– Save the job as categorical_spec.mat
– Press the “Run” button

• Press the REVIEW button (it is advisable to check the
model specification)
– Under the “Design” tab, select the first item

“Design Matrix”
– “Explore” → “Session 1” → “N1”



Step 9
Specify First-Level (Part 5)
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Step 9
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Step 10
Estimate

• Press the ESTIMATE button
– Highlight “Select SPM.mat” and select the

SPM.mat file saved in the DIR/categorical
directory

– Save the job as categorical_est.job
– Press the “Run” button
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Step 11
Inference for Categorical Design

• Press the RESULTS button
– Select the  SPM.mat file saved in the

DIR/categorical directory, choose contrast
number 5, and then press “Done”

• “Mask with other contrast?”; Click “No”
• “Title for comparison?”; Type “Canonical HRF:

Faces > Baseline”
• “p value adjustment to control”; Click “FWE”
• “Corrected p value (family-wise error)”;

Accept the default value, “0.05”
• “Extent threshold {voxels}”; Accept the default

value, “0”
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Step 11
Inference for Categorical Design



Step 12
Statistical Tables

• Press the WHOLE BRAIN button in the p-values
section of the interactive window
– x, y, z (mm) (coordinates in MNI space for each

maximum)
– Peak-level (chance of finding a peak with this or

a greater height)
– Cluster-level (chance of finding a cluster with this

many or a greater number of voxels)
– Set-level (chance of finding this or a greater

number of clusters in the search volume)
• Right-click on the MIP and select “goto global

maxima” (e.g., [39 -70 -14])
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Statistical Tables
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Step 12
Statistical Tables (Optional)

• Select SLICES from the “Overlays” drop-down menu
–  Select the  wmeansM03953_0005_0006.img file

and then press “Done”
• Click the PLOT button

– “Plot”; Click “Contrast of estimates and 90% C.I.”
– “Which contrast?…”; Click “Average effect of

condition”



Step 12
Statistical Tables (Optional)
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Step 12
Statistical Tables (Optional)



Step 13
F-Contrasts

• Press the RESULTS button
– Select the  SPM.mat file saved in the DIR/categorical

directory
– Select the “F-contrast” toggle, choose contrast number 3,

and then press “Done”
• “Mask with other contrast?”; Click “Yes” and select

contrast 5
• “Uncorrected mask p-value?”; Enter “0.001”
• “Nature of mask?”; Click “Inclusive”
• “Title for comparison?”; Click “Main effect of Rep…”
• “p value adjustment to control”; Click “None”
• “Threshold (F or p value)”; Accept the default value,

“0.001”
• “Extent threshold {voxels}”; Accept the default value,

“0”



Step 13
F-Contrasts
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Step 13
F-Contrasts



Step 13
F-Contrasts (Optional)

• Right-click on the MIP and select “goto global
maxima” (e.g., [42 -64 -8])

• Click the PLOT button
– “Plot”; Click “Event-related responses”
– “Which effect…”; Click “F1”
– “Plot in terms of…”; Click “Fitted response and

PSTH”



Step 13
F-Contrasts (Optional)
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Step 13
F-Contrasts (Optional)



Step 14
Testing Effects of Movement

• Press the RESULTS button
– Select the  SPM.mat file saved in the

DIR/categorical directory
– Specify “F-contrast” in the Contrast Manager

and “Movement-related effects” in the
“Contrasts weight matrix” window

– Submit and select the contrast
• “Mask with other contrast?”; Click “No”
• “Title for comparison?”; Accept the default
• “Corrected height threshold”; Select “FWE”
• “Corrected p value”; Accept the default

value, “0.05”
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Step 14
Testing Effects of Movement



Step 14
Testing Effects of Movement (Optional)

• Press the RESULTS button
– Select the  SPM.mat file saved in the DIR/categorical

directory
– Specify “F-contrast” in the Contrast Manager and

“Movement-related effects” in the “Contrasts weight
matrix” window

– Submit and select the contrast
• “Mask with other contrast?”; Click “No”
• “Title for comparison?”; Accept the default
• “Corrected height threshold”; Select “FWE”
• “Corrected p value”; Accept the default value, “0.05”



Step 14
Testing Effects of Movement (Optional)
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Step 14
Testing Effects of Movement (Optional)



fMRI Second-Level
Data Analysis



fMRI Data Files

• M2i (Using contrast images from an “informed” basis
set,consisting of the canonical HRF and its two
partial derivatives with respect to time (onset
latency) and dispersion)
– 12 (subjects) x 3 (basis functions) con*.imgs from

the first level model using the informed basis (M1i)

***Create an “Informed” subdirectory***



Step 1
One-Way ANOVA (Part 1)

• Press the SPECIFY 2ND-LEVEL button
– In “Factorial design specification”, highlight

“Design” and then choose “Full Factorial”
– Under “Factors” create a single “New Factor”

• “Factor”; Type in “Basis”
• “Levels”; Type “3”

– Highlight “Independence” and select “No”
– Highlight “Specify cells” and create 3 new cells

• “Levels”; Enter “1”, “2”, and “3” consecutively
• Enter the canonical contrast images under

scans (0003 to 0014, 0015 to 0026, and 0027 to
0038, respectively



Step 1
One-Way ANOVA (Part 2)

– Highlight “Directory”, then select “Specify files”,
and choose the subdirectory “informed” to
place the design matrix in

– Save the job files as DIR/informed.mat
– Press the “Run” button

• Press the ESTIMATE button to estimate the
parameters of the model
– Select the SPM.mat file just created
– Press the “Run” button



Step 2
Nonsphericity

• Go to “Review” → “Design” → “Explore” → “Covariance
Structure” to show the estimated covariance matrix
– SPM.xVI.Vi{1} (variance of the canonical derivative)
– SPM.xVi.Vi{2} (variance of the temporal derivative)
– SPM.xVi.Vi{3} (variance of the dispersion derivative)
– SPM.xVi.Vi{4} (covariance between canonical and

temporal derivative)
– SPM.xVi.Vi{5} (covariance between canonical and

dispersion derivative)
– SPM.xVi.Vi{6} (covariance between temporal and

dispersion derivatives)



Step 3
Informed Results (Part 1)

• Press the RESULTS button
– Select the SPM.mat file
– Press “Define new contrast” and select “F”

• “Contrast”; Type “eye(3)”
• “Name”; Enter “Faces vs. Baseline: Informed”
• Press the “Submit” button and then press OK
• Press the “Done” button

– “Mask with other contrast(s)?”; Click “No”
– “Title for comparison?”; Type “Faces vs Baseline:

Informed”
– “p value adjustment to control”; Click “FWE”
– “Family-wise p-value”; Type “0.05”
– “Extent threshold {voxels}”; Accept the default value,

“0”



Step 3
Informed Results (Part 2)

• Right click on the MIP and select “goto global
maxima”
– Press “plot”, select “Contrast estimates and 90%

C.I.”, and then select the “Faces vs Baseline:
Informed” contrast

– Compare the size of the first, second, and third
bars to the error bars in order to accurately
determine the contributions of the different basis
functions



Step 4
T- and F-Contrasts

• Press the RESULTS button
– Select the SPM.mat file
– Press “Define new contrast” and select “T”

• “Contrast”; Type “eye(3)”
• “Name”; Enter “Faces vs. Baseline: Informed”
• Press the “Submit” button and then press OK
• Press the “Done” button

– “Mask with other contrast(s)?”; Click “No”
– “Title for comparison?”; Type “Faces vs Baseline:

Informed”
– “p value adjustment to control”; Click “FWE”
– “Family-wise p-value”; Type “0.05”
– “Extent threshold {voxels}”; Accept the default value,

“0”



Congratulations!

You Successfully Processed
and Explored SPM’s fMRI

Dataset!


